[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Link to virdbustest against DBus libs



On Mon, Aug 12, 2013 at 10:13:07PM +0200, Guido Günther wrote:
> On Mon, Aug 12, 2013 at 01:21:08PM -0600, Eric Blake wrote:
> > On 08/12/2013 01:14 PM, Guido Günther wrote:
> > > otherwise we fail like:
> > > 
> > >     CCLD     virdbustest
> > >     /usr/bin/ld: virdbustest-virdbustest.o: undefined reference to symbol 'dbus_message_unref'
> > >     /lib/x86_64-linux-gnu/libdbus-1.so.3: error adding symbols: DSO missing from command line
> > >     collect2: error: ld returned 1 exit status
> > > 
> > > Found by:
> > > 
> > >     http://honk.sigxcpu.org:8001/job/libvirt-build-debian-sid-amd64/7/console
> > > ---
> > >  tests/Makefile.am | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > ACK.
> 
> I found several more places which fail to link with a strict
> --no-copy-dt-needed-entries. See my followup patch which superseeds this
> one.

Hmm, it sounds like we ought to make configure.ac automatically
add this linker flag if we can detect that it is supported.

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]