[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Always specify qcow2 compat level on qemu-img command line



On Fri, Aug 23, 2013 at 01:31:41PM +0200, Ján Tomko wrote:
> qemu-img is going to switch the default for QCOW2
> to QCOW2v3 (compat=1.1) [0]
> 
> Extend the probing for qemu-img command line options to check
> if -o compat is supported. If the volume definition specifies
> the qcow2 format but no compat level and -o compat is supported,
> specify -o compat=0.10 to create a QCOW2v2 image.
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=997977
> ---
> [0] the switch is not yet upstream. The proposed (incomplete) QEMU patch:
> http://lists.nongnu.org/archive/html/qemu-devel/2013-08/msg02549.html

ACK,

Incidentally, it sucks that while we've solved the capabilities
detection problem for QEMU avoiding the need to use -help or
similar args, we now re-introduce the problem for qemu-img.


Daniel.
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]