[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Libvirt multi queue support



Hi Michal

First of all thanks for your reply.

I followed your advice and the guideline you sent and did the following:

   <interface type='bridge'>
      <mac address='52:54:00:43:6e:3f'/>
      <source bridge='clients'/>
      <model type='virtio'/>
      <driver name='vhost' queues='5'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </interface>

virsh version reports the following:

Compiled against library: libvirt 1.1.1
Using library: libvirt 1.1.1
Using API: QEMU 1.1.1
Running hypervisor: QEMU 1.5.2

When I tried starting the machine I received the following:

error: Failed to start domain NaorDev
error: unsupported configuration: Multiqueue devices are not supported on this system

Could you please tell what am I missing?

Thanks,
Naor


-----Original Message-----
From: Michal Privoznik [mailto:mprivozn redhat com] 
Sent: Wednesday, August 21, 2013 2:51 PM
To: Naor Shlomo
Cc: libvir-list redhat com
Subject: Re: [libvirt] Libvirt multi queue support

On 21.08.2013 07:31, Naor Shlomo wrote:
> Hello experts,
> 
>  
> 
> Could anyone please tell me if Multi Queue it fully supported in 
> Libvirt and if so what version contains it?
> 

Do you mean multiqueue network? It's supported from 1.0.6. You can set it in /domain/devices/interface/driver/@queues attribute:

http://libvirt.org/formatdomain.html#elementsDriverBackendOptions

Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]