[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 2/3] util: use new virendian.h macros



On 02/11/2013 07:07 PM, Eric Blake wrote:
> This makes code easier to read, by avoiding lines longer than
> 80 columns and removing the repetition from the callers.
> 
> * src/util/virstoragefile.c (qedGetHeaderUL, qedGetHeaderULL):
> Delete in favor of more generic macros.
> (qcow2GetBackingStoreFormat, qcowXGetBackingStore)
> (qedGetBackingStore, virStorageFileMatchesVersion)
> (virStorageFileGetMetadataInternal): Use new macros.
> * src/cpu/cpu_x86.c (x86VendorLoad): Likewise.
> ---
>  src/cpu/cpu_x86.c         |  24 ++++------
>  src/util/virstoragefile.c | 109 ++++++++++------------------------------------
>  2 files changed, 30 insertions(+), 103 deletions(-)
> 

ACK


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]