[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Out of Memory Error



Thank you so much for the reply and for sharing the patch...I will try this tomorrow and then let you know whether it works or not.....And i'll try removing the <device> tag too.....
Thank you again for the help.... :)


On Thu, Feb 14, 2013 at 2:11 PM, Jiri Denemark <jdenemar redhat com> wrote:
On Thu, Feb 14, 2013 at 01:24:32 +0530, varun bhatnagar wrote:
> Hi,
>
> Today I noticed one strange thing. I* *removed the contents of
> *usbSharedFolder.xml
> *and kept it blank. Then I again tried both ways i.e. calling attachDevice
> method using code as well as virsh but again it gave libvir: VirtualBox
> Driver error : out of memory but I was expecting some syntactical error. Is
> this a bug....??

Yes, it's a bug. See
http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=2e5d7798df56621986bddd588b53827e6557687a
for the patch that is now in libvirt git repository.

> > I am trying to attach a usb device to my virtualbox node using libvirt. My
> > node is already running, I stop my node and then I am trying to add this
> > usb device.
> > I have a separate xml file defined for usb. It looks like this:
> >
> > *<device>
> > <hostdev mode='subsystem' type='usb'>
> >       <source>
> >         <vendor id='0x4321'/>
> >         <product id='0xfeeb'/>
> >       </source>
> > </hostdev>
> > </device> *

Btw, this XML is not correct. It should contain just the <hostdev>
element.

Jirka


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]