[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [hyperv]: Connection failure



I struggled with below issue for a while and playing with multiple tools avaialble on web to check if wsman was working, I found that issue was with libopenwsman version available for ubuntu. I switched the testbed to SL 6.1, installed libvirt on it and providing necessary openwsman libraries. I can perform basic set of operations. 
 
-A




From: ata husain hotmail com
To: libvir-list redhat com
Date: Wed, 13 Feb 2013 16:15:53 -0800
Subject: [libvirt] [hyperv]: Connection failure


Hi Everyone,
 
I installed a HyperV server and trying to connect to it using libvirt. As suggested by libvirt driver wiki (http://libvirt.org/drvhyperv.html), I've enabled Basic authentication on the server (and also enabled HTTP connection request for debugging purpose). Even after all this configuration, on connection I get error as:  
 
---------------

Enter Administrator's password for 10.y.y.y: xxxxxx
2013-02-14 00:02:25.122+0000: 6825: info : libvirt version: 1.0.2
2013-02-14 00:02:25.122+0000: 6825: error : hypervDebugHandler:1444 : openwsman error: NULL response
libvir: Hyper-V Driver error : internal error Transport error during enumeration: Could not connect (7)
Failed to open connection
libvir:  error : invalid connection pointer in virConnectGetHostname
Host name: (null)
libvir:  error : invalid connection pointer in virConnectClose
 
------------------------------
 
Hyper-V server configuration looks like:
xxx> winrm get winrm/config/service
Service
ROOTSDDL = <long string>
MaxConnectionOperations = 4294967295
MaxConnectionOperationsPerUser = 1500
MaxConnectionTimeoutms = 240000
MaxConnections = 300
MaxPacketRetrievalTimeSeconds = 120
AllowUnencrypted = true
Auth
   Basic = true
  .....
.
.
.
AllowRemoteAccess = true
 
------------------------------
 
I'm have libvirt on ubuntu (3.2.0-37-generic) and openwsman is 2.2.3-oubuntu4 version.
 
Also, I'm using "Administrator" credentials to connect to HyperV server.
 
Please suggest what is missing from my setup.

Thanks!
Ata

-- libvir-list mailing list libvir-list redhat com https://www.redhat.com/mailman/listinfo/libvir-list

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]