[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Compile libvirt V1.0.1 error



Hi all,

When i compiled libvirt like following

  1. git clone git://libvirt.org/libvirt.git;cd libvirt
  2. git reset --hard v1.0.1
  3. wget http://cloudxy.googlecode.com/svn/branches/hlfs/person/harry/hlfs/patches/hlfs_driver_for_libvirt_network_disk.patch
  4. wget http://cloudxy.googlecode.com/svn/branches/hlfs/person/harry/hlfs/patches/hlfs_driver_for_libvirt_add_classpath.patch
  5. git apply hlfs_driver_for_libvirt_network_disk.patch
  6. git apply hlfs_driver_for_libvirt_add_classpath.patch
  7. ./autogen.sh
  8. ./configure
  9. make

i got following errors.

[...]
cc1: error: AVA_HOME/include: No such file or directory [-Werror]
cc1: error: AVA_HOME/include/linux: No such file or directory [-Werror]
cc1: all warnings being treated as errors
make[3]: *** [libvirt_driver_storage_impl_la-storage_driver.lo] Error 1
make[3]: Leaving directory `/home/jiawei/workshop1/libvirt/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/jiawei/workshop1/libvirt/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jiawei/workshop1/libvirt'
make: *** [all] Error 2


It seems that the errors have no relationship with HLFS(the patches i patched)
but AVA_HOME.

Could anyone give me some suggestions? Thanks in advance ;-)


-- 
Thanks
Harry Wei


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]