[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/4] rename qemuGetNumadAdvice to virDomainGetNumadAdvice



On Wed, Feb 27, 2013 at 04:09:35PM +0800, Gao feng wrote:
> qemuGetNumadAdvice will be used by LXC driver,rename
> it to virDomainGetNumaAdvice and move it to domain_conf.c
> 
> Signed-off-by: Gao feng <gaofeng cn fujitsu com>
> ---
>  src/conf/domain_conf.c   | 31 +++++++++++++++++++++++++++++++
>  src/conf/domain_conf.h   |  2 ++
>  src/libvirt_private.syms |  1 +
>  src/qemu/qemu_process.c  | 32 +-------------------------------
>  4 files changed, 35 insertions(+), 31 deletions(-)

Ewww no. The domain_conf.c file is for XML configuration
parsing & formatting. Code dealing with numad has no
business being there.

We don't currently have any place for general NUMA related
helper APIs, so I'd suggest you create a new pair of files
for these methods src/util/virnuma.h and src/util/virnuma.c

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]