[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 3/4] remove the redundant codes



On Wed, Feb 27, 2013 at 04:09:37PM +0800, Gao feng wrote:
> Intend to reduce the redundant code,use virDomainSetupNumaMemoryPolicy
> to replace virLXCControllerSetupNUMAPolicy and qemuProcessInitNumaMemoryPolicy.
> 
> Signed-off-by: Gao feng <gaofeng cn fujitsu com>
> ---
>  src/conf/domain_conf.c   | 113 +++++++++++++++++++++++++++++++++++
>  src/conf/domain_conf.h   |   2 +

Again, this is not a suitable place for this code. It'll want to
go in src/util/virnuma.c too. NB, you'll need to move the
virDomainNumatuneDef struct definition out of domain_conf.h and
rename it to 'virNumaTuneParams' in the src/util/virnuma.h file


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]