[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH libvirt-java 9/9] Add resize flags to StorageVol



On Mon, Jan 07, 2013 at 12:38:16 +0100, Claudio Bley wrote:
...
> Additionally, consensus was that we should drop the C prefixes from
> enum values when wrapping them in Java. I will do this for existing
> enums when I find the time, but for new enums we could just as well
> avoid introducing them in the first place.
> 
> In this case the prefix of VIR_DOMAIN_BLOCK_RESIZE should be
> removed. Usage would thus be
> 
> Domain.BlockResizeFlags.BYTES

This is certainly good for new enums, however, you need to be careful
when changing existing enums. You would need to keep the long names for
backward compatibility.

Jirka


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]