[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH libvirt-java 9/9] Add resize flags to StorageVol

At Mon, 7 Jan 2013 16:41:14 +0100,
Jiri Denemark wrote:
> On Mon, Jan 07, 2013 at 12:38:16 +0100, Claudio Bley wrote:
> ...
> > Additionally, consensus was that we should drop the C prefixes from
> > enum values when wrapping them in Java. I will do this for existing
> > enums when I find the time, but for new enums we could just as well
> > avoid introducing them in the first place.
> > 
> > In this case the prefix of VIR_DOMAIN_BLOCK_RESIZE should be
> > removed. Usage would thus be
> > 
> > Domain.BlockResizeFlags.BYTES
> This is certainly good for new enums, however, you need to be careful
> when changing existing enums. You would need to keep the long names for
> backward compatibility.

This is certainly true.

But there are some issues that require changing the API without being
able to provide backward compatibility. (Changing method return types,
without changing their parameter list, so overloading does not help

The plan is to drop backward compatibility at some point and fix all
of those issues. Probably in libvirt-java 0.5.x.

AV-Test GmbH, Henricistra├če 20, 04155 Leipzig, Germany
Phone: +49 341 265 310 19

Eingetragen am / Registered at: Amtsgericht Stendal (HRB 114076)
Geschaeftsfuehrer (CEO): Andreas Marx, Guido Habicht, Maik Morgenstern

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]