[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Convert libxl driver to Xen 4.2



On 12/06/2012 03:18 PM, Eric Blake wrote:
> On 11/30/2012 03:13 PM, Jim Fehlig wrote:
>> Based on a patch originally authored by Daniel De Graaf
>>
>>   http://lists.xen.org/archives/html/xen-devel/2012-05/msg00565.html
>>
>> This patch converts the Xen libxl driver to support only Xen >= 4.2.
>> Support for Xen 4.1 libxl is dropped since that version of libxl is
>> designated 'technology preview' only and is incompatible with Xen 4.2
>> libxl.  Additionally, the default toolstack in Xen 4.1 is still xend,
>> for which libvirt has a stable, functional driver.
>> ---
>> V2:
>>   Remove 128 vcpu limit.
>>   Remove split_string_into_string_list() function copied from xen
>>   sources since libvirt now has virStringSplit().
> 
> Tested on Fedora 18, with its use of xen 4.2.  ACK; let's get this pushed.

I've also backported this to v0.10.2-maint, since that is the branch
used for F18 libvirt.  I had some merge conflicts to resolve, so I'll
reply to this message with the actual patches that I pushed, if anyone
is interested in double-checking them.  I went ahead and pushed the
backports under the build-breaker rule (as it was interfering with me
backporting some other patches to v0.10.2-maint on my F18 box).

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]