[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Slow libvirtd startup



Hi,
  Too lazy to explain again so I'll just c&p conversation I had about
the issue with Eric on IRC:

<zeenix> is timeouts on session libvirt (or in general) something new?
<zeenix> libvirtd startup seems to now take a few seconds so Boxes UI
is all empty for that amount of time
<eblake> it's been around for a while; qemu.conf has settings to
control how long it should take
<zeenix> unless Boxes is launched before libvirtd timesout
<eblake> but there is a relatively new patch that makes the libvirtd
-t actually be useful for qemu:///session
<zeenix> don't think i ever changed that, at least not recently
<zeenix> that could be it
<zeenix> i only saw it happening after i update libvirtd (after a month)
<eblake> if you're seeing some delays in starting libvirtd, those are
probably worth fixing
<zeenix> s/update/recently updated/
<zeenix> yeah
<zeenix> i'll try to write a test app
<zeenix> no need, i can reproduce with virsh :)

[zeenix z-laptop virt]$ time virsh list
 Id    Name                           State
----------------------------------------------------


real	0m6.349s
user	0m0.016s
sys	0m0.010s
[zeenix z-laptop virt]$ time virsh list
 Id    Name                           State
----------------------------------------------------


real	0m0.024s
user	0m0.010s
sys	0m0.011s


-- 
Regards,

Zeeshan Ali (Khattak)
FSF member#5124


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]