[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] build: require avahi instead of avahi-libs on rhel5.



On rhel5, libs of avahi are packaged into avahi instead of avahi-libs.
Actually, there is no avahi-libs package shipped with rhel5. This patch
fixes this by requiring avahi on rhel5.
---
 libvirt.spec.in |    4 ++++
 1 files changed, 4 insertions(+), 0 deletions(-)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index d095eac..3362d3f 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -615,8 +615,12 @@ Requires: module-init-tools
 # for /sbin/ip & /sbin/tc
 Requires: iproute
 %if %{with_avahi}
+%if 0%{?rhel} == 5
+Requires: avahi
+%else
 Requires: avahi-libs
 %endif
+%endif
 %if %{with_network}
 Requires: dnsmasq >= 2.41
 Requires: radvd
-- 
1.7.4.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]