[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH 12/28] Convert avahi check to use LIBVIRT_CHECK_PKG



From: "Daniel P. Berrange" <berrange redhat com>

Signed-off-by: Daniel P. Berrange <berrange redhat com>
---
 configure.ac     | 34 ++--------------------------------
 m4/virt-avahi.m4 | 26 ++++++++++++++++++++++++++
 2 files changed, 28 insertions(+), 32 deletions(-)
 create mode 100644 m4/virt-avahi.m4

diff --git a/configure.ac b/configure.ac
index c88162e..b2960b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,7 +98,6 @@ fi
 dnl Required minimum versions of all libs we depend on
 LIBXML_REQUIRED="2.6.0"
 GNUTLS_REQUIRED="1.0.25"
-AVAHI_REQUIRED="0.6.0"
 POLKIT_REQUIRED="0.6"
 PARTED_REQUIRED="1.8.0"
 UDEV_REQUIRED=145
@@ -155,6 +154,7 @@ LIBVIRT_COMPILE_WARNINGS
 
 LIBVIRT_CHECK_APPARMOR
 LIBVIRT_CHECK_AUDIT
+LIBVIRT_CHECK_AVAHI
 LIBVIRT_CHECK_CAPNG
 LIBVIRT_CHECK_DBUS
 LIBVIRT_CHECK_NETCF
@@ -1171,32 +1171,6 @@ if test "x$with_firewalld" == "xyes" ; then
 fi
 AM_CONDITIONAL([HAVE_FIREWALLD], [test "x$with_firewalld" != "xno"])
 
-dnl Avahi library
-AC_ARG_WITH([avahi],
-  AC_HELP_STRING([--with-avahi], [use avahi to advertise remote daemon @<:@default=check@:>@]),
-  [],
-  [with_avahi=check])
-
-AVAHI_CFLAGS=
-AVAHI_LIBS=
-if test "x$with_avahi" = "xyes" || test "x$with_avahi" = "xcheck"; then
-  PKG_CHECK_MODULES(AVAHI, avahi-client >= $AVAHI_REQUIRED,
-    [with_avahi=yes], [
-    if test "x$with_avahi" = "xcheck" ; then
-       with_avahi=no
-    else
-       AC_MSG_ERROR(
-         [You must install Avahi >= $AVAHI_REQUIRED to compile libvirt])
-    fi
-  ])
-  if test "x$with_avahi" = "xyes" ; then
-    AC_DEFINE_UNQUOTED([WITH_AVAHI], 1,
-      [whether Avahi is used to broadcast server presense])
-  fi
-fi
-AC_SUBST([AVAHI_CFLAGS])
-AC_SUBST([AVAHI_LIBS])
-
 
 dnl UUCP style file locks for character devices
 if test "$with_chrdev_lock_files" != "no"; then
@@ -2687,6 +2661,7 @@ AC_MSG_NOTICE([Libraries])
 AC_MSG_NOTICE([])
 LIBVIRT_RESULT_APPARMOR
 LIBVIRT_RESULT_AUDIT
+LIBVIRT_RESULT_AVAHI
 LIBVIRT_RESULT_CAPNG
 LIBVIRT_RESULT_DBUS
 LIBVIRT_RESULT_NETCF
@@ -2718,11 +2693,6 @@ else
 AC_MSG_NOTICE([  gnutls: no])
 fi
 AC_MSG_NOTICE([firewalld: $with_firewalld])
-if test "$with_avahi" = "yes" ; then
-AC_MSG_NOTICE([   avahi: $AVAHI_CFLAGS $AVAHI_LIBS])
-else
-AC_MSG_NOTICE([   avahi: no])
-fi
 if test "$with_polkit" = "yes" ; then
 if test "$with_polkit0" = "yes" ; then
 AC_MSG_NOTICE([  polkit: $POLKIT_CFLAGS $POLKIT_LIBS (version 0)])
diff --git a/m4/virt-avahi.m4 b/m4/virt-avahi.m4
new file mode 100644
index 0000000..d0ac86c
--- /dev/null
+++ b/m4/virt-avahi.m4
@@ -0,0 +1,26 @@
+dnl The libavahi.so library
+dnl
+dnl Copyright (C) 2012-2013 Red Hat, Inc.
+dnl
+dnl This library is free software; you can redistribute it and/or
+dnl modify it under the terms of the GNU Lesser General Public
+dnl License as published by the Free Software Foundation; either
+dnl version 2.1 of the License, or (at your option) any later version.
+dnl
+dnl This library is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+dnl Lesser General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU Lesser General Public
+dnl License along with this library.  If not, see
+dnl <http://www.gnu.org/licenses/>.
+dnl
+
+AC_DEFUN([LIBVIRT_CHECK_AVAHI],[
+  LIBVIRT_CHECK_PKG([AVAHI], [avahi-client], [0.6.0])
+])
+
+AC_DEFUN([LIBVIRT_RESULT_AVAHI],[
+  LIBVIRT_RESULT_LIB([AVAHI])
+])
-- 
1.7.11.7


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]