[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/5] schema: Make the cpuset type reusable across schema files



On 01/19/2013 12:06 AM, Peter Krempa wrote:
> ---
>  docs/schemas/basictypes.rng   | 6 ++++++
>  docs/schemas/domaincommon.rng | 5 -----
>  2 files changed, 6 insertions(+), 5 deletions(-)
> 
> diff --git a/docs/schemas/basictypes.rng b/docs/schemas/basictypes.rng
> index 38cab16..8e44e8d 100644
> --- a/docs/schemas/basictypes.rng
> +++ b/docs/schemas/basictypes.rng
> @@ -219,4 +219,10 @@
>      </data>
>    </define>
> 
> +  <define name="cpuset">
> +    <data type="string">
> +      <param name="pattern">([0-9]+(-[0-9]+)?|\^[0-9]+)(,([0-9]+(-[0-9]+)?|\^[0-9]+))*</param>
> +    </data>
> +  </define>
> +
>  </grammar>
> diff --git a/docs/schemas/domaincommon.rng b/docs/schemas/domaincommon.rng
> index 67ae864..008a62f 100644
> --- a/docs/schemas/domaincommon.rng
> +++ b/docs/schemas/domaincommon.rng
> @@ -3672,11 +3672,6 @@
>    <!--
>         Type library
>      -->
> -  <define name="cpuset">
> -    <data type="string">
> -      <param name="pattern">([0-9]+(-[0-9]+)?|\^[0-9]+)(,([0-9]+(-[0-9]+)?|\^[0-9]+))*</param>
> -    </data>
> -  </define>
>    <define name="countCPU">
>      <data type="unsignedShort">
>        <param name="pattern">[0-9]+</param>
> 

I'd suggest naming this type 'bitmap' to possibly accommodate other bit
maps in the future, but since this was pre-existing it has nothing to do
with this patch, just sayin'.

ACK,

Martin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]