[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Libvirt]Install Libvirt errors



On Thu, Jan 31, 2013 at 2:52 AM, Eric Blake <eblake redhat com> wrote:
[...]
>
>> [...]
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libxslt.so.1)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libxslt.so.1)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libxslt.so.1)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libxslt.so.1)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libxslt.so.1)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libxslt.so.1)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libxslt.so.1)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libexslt.so.0)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libexslt.so.0)
>> /usr/bin//xsltproc: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libexslt.so.0)
>> /usr/bin//xmlcatalog: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/bin//xmlcatalog)
>> missing XHTML1 DTD
>> Generating drvphyp.html.tmp
>
> I'm not sure why your xsltproc is so noisy (it's probably a broken
> install that you ought to look into fixing), but that it outside the
> scope of the libvirt list.  Meanwhile, your problem is definitely
> related to the fact that you don't have enough developer tools
> installed, but you are trying to build from git, and therefore the html
> files aren't pre-built.  If you use the official libvirt 1.0.2 tarball
> (released today) instead of building from git, you would not have this
> problem.  Otherwise, it sounds like you need to install the proper DTD
> files for generating the html files, before 'make install' has a chance
> of working.  On Fedora, the packages are named xhtml1-dtds and
> docbook-dtds; I'm not sure what they are named on other distros.
>

In Ubuntu 10.04 desktop, i installed following packages and soloved
up errors.

$sudo aptitude install libghc6-xhtml-dev
$sudo aptitude install w3c-dtd-xhtml
$sudo aptitude install dtdinst

Eric, thanks for your help ;-)


-- 
Thanks
Harry Wei


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]