[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] build: avoid build failure without gnutls

Found while trying to cross-compile to mingw:

  CC       libvirt_driver_remote_la-remote_driver.lo
../../src/remote/remote_driver.c: In function 'doRemoteOpen':
../../src/remote/remote_driver.c:487:23: error: variable 'verify' set but not used [-Werror=unused-but-set-variable]

* src/remote/remote_driver.c (doRemoteOpen): Also ignore 'verify'.

Signed-off-by: Eric Blake <eblake redhat com>

Pushing under the build-breaker rule.

I also had a report that libvirt fails to compile for mingw on
Fedora 19; it looks like a gnulib submodule update will fix
part of that issue, so I'm working on that now...

 src/remote/remote_driver.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/src/remote/remote_driver.c b/src/remote/remote_driver.c
index 7a0c1f6..7f3e833 100644
--- a/src/remote/remote_driver.c
+++ b/src/remote/remote_driver.c
@@ -609,6 +609,7 @@ doRemoteOpen(virConnectPtr conn,
         priv->is_secure = 1;
+        (void)verify;
         virReportError(VIR_ERR_INVALID_ARG, "%s",
                        _("GNUTLS support not available in this build"));
         goto failed;

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]