[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] qemu64 - not valid cpu with 'Intel Westmere Family'



Il 03/07/2013 16:40, Sandro Bonazzola ha scritto:
> Hi,
> I'm trying to run latest vdsm master on RHEL-6.4.
> I've built the rpms against livirt-1.10    
>
> I'm creating a VM using cpu family = 'Intel Westmere Family'
>
> <cpu match="exact">
>      <model>qemu64</model>
>      <feature name="svm" policy="disable"/>
> </cpu>
>
> Thread-40::DEBUG::2013-07-03
> 15:47:47,150::libvirtconnection::136::vds::(wrapper) Unknown
> libvirterror: ecode: 1 edom: 31 level: 2 message: internal error Cannot
> find suitable CPU model for given data
> Thread-40::DEBUG::2013-07-03
> 15:47:47,150::vm::2003::vm.Vm::(_startUnderlyingVm)
> vmId=`9deae1fb-e0c5-4362-8f3c-657f39893b8b`::_ongoingCreations released
> Thread-40::ERROR::2013-07-03
> 15:47:47,150::vm::2029::vm.Vm::(_startUnderlyingVm)
> vmId=`9deae1fb-e0c5-4362-8f3c-657f39893b8b`::The vm start process failed
> Traceback (most recent call last):
>   File "/usr/share/vdsm/vm.py", line 1989, in _startUnderlyingVm
>     self._run()
>   File "/usr/share/vdsm/vm.py", line 2862, in _run
>     self._connection.createXML(domxml, flags),
>   File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py",
> line 112, in wrapper
>     ret = f(*args, **kwargs)
>   File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2848, in
> createXML
>     if ret is None:raise libvirtError('virDomainCreateXML() failed',
> conn=self)
> libvirtError: internal error Cannot find suitable CPU model for given data
>
>
> Is it required a more updated qemu? Is it a vdsm or a livirt bug?


It seems that qemu knows qemu64 as cpu

#  /usr/libexec/qemu-kvm  --cpu ?
x86       Opteron_G5  AMD Opteron 63xx class CPU                     
x86       Opteron_G4  AMD Opteron 62xx class CPU                     
x86       Opteron_G3  AMD Opteron 23xx (Gen 3 Class Opteron)         
x86       Opteron_G2  AMD Opteron 22xx (Gen 2 Class Opteron)         
x86       Opteron_G1  AMD Opteron 240 (Gen 1 Class Opteron)          
x86          Haswell  Intel Core Processor (Haswell)                 
x86      SandyBridge  Intel Xeon E312xx (Sandy Bridge)               
x86         Westmere  Westmere E56xx/L56xx/X56xx (Nehalem-C)         
x86          Nehalem  Intel Core i7 9xx (Nehalem Class Core i7)      
x86           Penryn  Intel Core 2 Duo P9xxx (Penryn Class Core 2)   
x86           Conroe  Intel Celeron_4x0 (Conroe/Merom Class Core 2)  
x86      cpu64-rhel5  QEMU Virtual CPU version (cpu64-rhel5)         
x86      cpu64-rhel6  QEMU Virtual CPU version (cpu64-rhel6)         
x86             n270  Intel(R) Atom(TM) CPU N270   @ 1.60GHz         
x86           athlon  QEMU Virtual CPU version 0.12.1                
x86         pentium3                                                 
x86         pentium2                                                 
x86          pentium                                                 
x86              486                                                 
x86          coreduo  Genuine Intel(R) CPU           T2600  @ 2.16GHz
x86           qemu32  QEMU Virtual CPU version 0.12.1                
x86            kvm64  Common KVM processor                           
x86         core2duo  Intel(R) Core(TM)2 Duo CPU     T7700  @ 2.40GHz
x86           phenom  AMD Phenom(tm) 9550 Quad-Core Processor        
x86           qemu64  QEMU Virtual CPU version 0.12.1   




>
>
> libvirt-1.1.0-1.el6.x86_64
> libvirt-client-1.1.0-1.el6.x86_64
> libvirt-daemon-1.1.0-1.el6.x86_64
> libvirt-daemon-config-network-1.1.0-1.el6.x86_64
> libvirt-daemon-config-nwfilter-1.1.0-1.el6.x86_64
> libvirt-daemon-driver-interface-1.1.0-1.el6.x86_64
> libvirt-daemon-driver-lxc-1.1.0-1.el6.x86_64
> libvirt-daemon-driver-network-1.1.0-1.el6.x86_64
> libvirt-daemon-driver-nodedev-1.1.0-1.el6.x86_64
> libvirt-daemon-driver-nwfilter-1.1.0-1.el6.x86_64
> libvirt-daemon-driver-qemu-1.1.0-1.el6.x86_64
> libvirt-daemon-driver-secret-1.1.0-1.el6.x86_64
> libvirt-daemon-driver-storage-1.1.0-1.el6.x86_64
> libvirt-daemon-kvm-1.1.0-1.el6.x86_64
> libvirt-daemon-lxc-1.1.0-1.el6.x86_64
> libvirt-debuginfo-1.1.0-1.el6.x86_64
> libvirt-devel-1.1.0-1.el6.x86_64
> libvirt-docs-1.1.0-1.el6.x86_64
> libvirt-lock-sanlock-1.1.0-1.el6.x86_64
> libvirt-python-1.1.0-1.el6.x86_64
> qemu-img-0.12.1.2-2.355.el6_4.5.x86_64
> qemu-kvm-0.12.1.2-2.355.el6_4.5.x86_64
> vdsm-4.11.0-84.gitc4e3dd0.el6.x86_64
> vdsm-cli-4.11.0-84.gitc4e3dd0.el6.noarch
> vdsm-gluster-4.11.0-84.gitc4e3dd0.el6.noarch
> vdsm-python-4.11.0-84.gitc4e3dd0.el6.x86_64
> vdsm-python-cpopen-4.11.0-84.gitc4e3dd0.el6.x86_64
> vdsm-xmlrpc-4.11.0-84.gitc4e3dd0.el6.noarch
>


-- 
Sandro Bonazzola
Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]