[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Rename VIR_DOMAIN_PAUSED_GUEST_PANICKED to VIR_DOMAIN_PAUSED_CRASHED



On 07/29/2013 10:56 AM, Daniel P. Berrange wrote:
> From: "Daniel P. Berrange" <berrange redhat com>
> 
> The VIR_DOMAIN_PAUSED_GUEST_PANICKED constant is badly named,
> leaking the QEMU event name. Elsewhere in the API we use
> 'CRASHED' rather than 'PANICKED', and the addition of 'GUEST'
> is redundant since all events are guest related.
> 
> Thus rename it to VIR_DOMAIN_PAUSED_CRASHED, which matches
> with VIR_DOMAIN_RUNNING_CRASHED and VIR_DOMAIN_EVENT_CRASHED.
> 
> It was added in commit 14e7e0ae8db9843aea80245a3d9e6cf5f2ef720d
> which post-dates v1.1.0, so is safe to rename before 1.1.1
> 
> Signed-off-by: Daniel P. Berrange <berrange redhat com>
> ---
>  include/libvirt/libvirt.h.in | 2 +-
>  src/qemu/qemu_monitor.c      | 2 +-
>  src/qemu/qemu_process.c      | 2 +-
>  tools/virsh-domain-monitor.c | 4 ++--
>  4 files changed, 5 insertions(+), 5 deletions(-)

ACK.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]