[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirtd 1.0.6 refuses to start



On 12/06/13 15:49, Michal Privoznik wrote:
On 11.06.2013 16:59, Franky Van Liedekerke wrote:
I just downloaded and compiled libvirtd on the same server as I did
1.0.4. Upon updating, libvirtd refuses to start, with this in the
logfile (obfuscated the hostname by xxx's):

2013-06-11 13:43:49.154+0000: 3336: info : libvirt version: 1.0.6,
package: 1.el6 (Unknown, 2013-06-06-14:57:07, xxxxxxxx)
2013-06-11 13:43:49.154+0000: 3336: error : virFileReadAll:1195 : Failed
to open file '/sys/class/fc_host//host0/max_npiv_vports': No such file
or directory
2013-06-11 13:43:49.159+0000: 3336: error : detect_scsi_host_caps:87 :
Failed to read max_npiv_vports for host1
2013-06-11 13:43:49.163+0000: 3336: error : virFileReadAll:1195 : Failed
to open file '/sys/class/fc_host//host0/max_npiv_vports': No such file
or directory
2013-06-11 13:43:49.163+0000: 3336: error : detect_scsi_host_caps:87 :
Failed to read max_npiv_vports for host2
2013-06-11 13:43:49.386+0000: 3336: error : virLockManagerPluginNew:175
: Failed to load plugin /usr/lib64/libvirt/lock-driver/lockd.so:
/usr/lib64/libvirt/lock-driver/lockd.so: undefined symbol:
virProcessGetStartTime
This symbol has been introduced in 1.0.6. So I guess you are running a
new binary with old libraries which causes your problem.

2013-06-11 13:43:49.386+0000: 3336: error : virStateInitialize:831 :
Initialization of QEMU state driver failed
2013-06-11 13:43:49.386+0000: 3336: error : daemonRunStateInit:887 :
Driver state initialization failed

So it seems two issues are present here:

1) it searches for /sys/class/fc_host//host0/max_npiv_vports for both
host1 and host2. Imho this path needs to be
/sys/class/fc_host//host1/max_npiv_vports and
/sys/class/fc_host//host2/max_npiv_vports respectively.

I guess you're right. Osier?


Yes, it's expected so.

It reports the correct host number.

2013-06-11 13:43:49.159+0000: 3336: error : detect_scsi_host_caps:87 :
Failed to read max_npiv_vports for host1

But produces incorrect file path with the same host number. However,
I have no idea why it happened from code. And we have test for the
util helpers. If it has problems, the test should fail too.

Osier


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]