[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Libvirt-announce] Candidate release 2 for libvirt-1.1.0



On 27/06/2013, at 5:01 PM, Daniel Veillard wrote:
>   I have just tagged the release candidate 2 in git and sent a tarball
> to the usual place (rpms are coming):
>   ftp://libvirt.org/libvirt/

Sorry for the delay, only just now remembered to test this. :)

Compilation is failing on OSX 10.7 x64 with:

**************************************************************
  CC     libvirt_util_la-virnetdevveth.lo
  CC     libvirt_util_la-virnetdevvlan.lo
  CC     libvirt_util_la-virnetdevvportprofile.lo
  CC     libvirt_util_la-virnetlink.lo
  CC     libvirt_util_la-virnodesuspend.lo
  CC     libvirt_util_la-virnuma.lo
util/virnetdevtap.c:315:26: error: use of undeclared identifier 'IF_MAXUNIT'
        for (i = 0; i <= IF_MAXUNIT; i++) {
                         ^
1 error generated.
make[3]: *** [libvirt_util_la-virnetdevtap.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
[all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
**************************************************************

There doesn't seem to be a definition for IF_MAXUNIT on OSX (10.7
anyway):

  $ grep -ri IF_MAXUNIT /usr/include/
  $

Interestingly, it's also not on a RHEL 6.4 box locally here
either:

  $ grep -ri "IF_MAXUNIT" /usr/include/
  $

Though, it's possible that box is missing required devel packages
for libvirt. (unsure)

Googling shows IF_MAXUNIT in context of FreeBSD stuff.  Not sure
of the right approach here.  eg exclude compiling this on OSX,
or alternatively make-it-work on OSX.

Hope that helps. :)

+ Justin

--
Open Source and Standards @ Red Hat

twitter.com/realjustinclift


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]