[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/7] Rename 'clone' to 'cloneFrom' to avoid name clash with clone() syscall



On Thu, Mar 07, 2013 at 06:14:45PM +0100, Peter Krempa wrote:
> On 03/07/13 17:41, Daniel P. Berrange wrote:
> >From: "Daniel P. Berrange" <berrange redhat com>
> >
> >On RHEL-4 vintage one of the header files is polluted causing a
> >clash between the clone() syscall and the 'clone' parameter in
> >a libvirt driver API
> >
> >Signed-off-by: Daniel P. Berrange <berrange redhat com>
> >---
> >  src/driver.h | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> >diff --git a/src/driver.h b/src/driver.h
> >index f60bf93..0931be2 100644
> >--- a/src/driver.h
> >+++ b/src/driver.h
> >@@ -1443,7 +1443,7 @@ typedef char *
> >  typedef virStorageVolPtr
> >      (*virDrvStorageVolCreateXMLFrom)         (virStoragePoolPtr pool,
> >                                                const char *xmldesc,
> >-                                              virStorageVolPtr clone,
> >+                                              virStorageVolPtr clonefrom,
> 
> libvirt.c uses "clonevol" here.

Good point, i'll make it consistent here

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]