[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] One problem of libvirt for fc18.



On 12.03.2013 07:45, Li Zhang wrote:
> Hi all,
> 
> We are trying to compile libvirt on fc18.
> But it always reports such a problem with rpcgen.
> 
> "make" fails:
>   GEN      lxc/lxc_monitor_protocol.h
> /usr/bin/rpcgen: C preprocessor failed with exit code 1
> cannot shutdown /usr/bin/rpcgen:  at ./rpc/genprotocol.pl line 124.
> make[2]: *** [lxc/lxc_monitor_protocol.h] Error 1
> 
> This should be the problem when executing rpcgen on fc18.
> 
> [root xxx libvirt]$ rpcgen --version
> rpcgen (GNU libc) 2.16
> 
> Any idea on how to resolve it or do a workaround?
> 
> Thanks a lot. :)
> --Li


I just powered on my F18, and successfully build libvirt from scratch.
I've got the very same rpcgen as you have. Do you build the most recent
git HEAD?

Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]