[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/4] rename qemuGetNumadAdvice to virGetNumadAdvice



On Fri, Mar 15, 2013 at 04:13:30PM +0800, Osier Yang wrote:
> On 2013年03月01日 14:52, Gao feng wrote:
> >qemuGetNumadAdvice will be used by LXC driver,rename
> >it to virGetNumaAdvice and move it to virnuma.c
> 
> s/virGetNumaAdvice/virGetNumadAdvice/,
> 
> >diff --git a/src/util/virnuma.h b/src/util/virnuma.h
> >new file mode 100644
> >index 0000000..b9046c2
> >--- /dev/null
> >+++ b/src/util/virnuma.h
> >+
> >+char *virGetNumadAdvice(unsigned short vcups,
> >+                        unsigned long long balloon);
> >+
> >+#endif /* __VIR_NUMA_H__ */
> 
> ACK with the small nits fixed. It's good to have virnuma.{h,c} for
> numa stuffs, I guess now we can move many codes into it.

Function names should always aim to match the filename. So i'd rename
this to   virNumaGetAutoPlacementAdvice()


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]