[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt-tck test failure with identity patches



On Wed, Mar 20, 2013 at 08:15:31PM +0100, Guido Günther wrote:
> Hi,
> the qemu session libvirt-tck test currently fails with:
> 
> [19:58:21] scripts/domain/050-transient-lifecycle.t ............ ok    59684 ms
> [19:59:20] scripts/domain/051-transient-autostart.t ............ ok     2001 ms
> [19:59:22] scripts/domain/060-persistent-lifecycle.t ........... ok     2943 ms
> [19:59:25] scripts/domain/061-persistent-autostart.t ........... ok     2050 ms
> [19:59:28] scripts/domain/065-persistent-redefine.t ............ ok     2050 ms
> [19:59:30] scripts/domain/070-transient-to-persistent.t ........ ok     2025 ms
> [19:59:32] scripts/domain/080-unique-id-define.t ............... ok     3353 ms
> [19:59:35] scripts/domain/081-unique-id-create.t ............... Dubious, test returned 22 (wstat 5632, 0x1600)
> All 12 subtests passed 
> [19:59:41] scripts/domain/082-unique-id-caching.t .............. Bailout called.  Further testing stopped:  failed to setup test harness: libvirt error code: 1, message: internal error Cannot initialize thread local for current identity
> 
> Runnig 081-unique-id-create.t and 082-unique-id-caching.t separately
> works so there's some corruption going on. Any idea what could be
> triggering this? It stared with one of:
> 
> ebf78be4c277cffae57d99daa199a9b3c1cf9804 Set the current client identity during API call dispatch
> d5e83ad9b7c74e434349ede076dc573a3cc50384 Add ability to get a virIdentity from a virNetServerClientPtr
> 8c5d28c1ad5d42b8f3599d52a3dfed32f88c4edc Add API to get the system identity
> 8726e91b3a165fa1094155218f3a3b65dbc932c5 Add APIs for associating a virIdentityPtr with the current thread
> 3aabe27247711324df2bfa623e9a5e8d2442e3a5 Define internal APIs for managing identities
> 51997e50fa9a54c4bfce3cb2dd43b53418135d18 Add APIs to get at more client security data
> 
> Any idea? I'll try to dig deeper once I find some more time.

There were some typos causing the "one time" intializer to be
run many times with predictably bad results :-) I've pushed a
fix


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]