[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] libxl driver issue with console/virt-viewer



Hi Jim, everyone,

I'm having an issue using the libvirt's libxl driver while installing a
Fedora 18 (via netinstall) on both Fedora 18 or rawhide host.

So, what happens is, basically, that I do not see the output from the
installer at all, neither in the virt-viewer instance that virt-install
does pop-up automatically, nor trying to manually connect to the VM
(either with virt-viewer or VNC). So, when I do:

[xen zhaman ~]$ sudo virt-install --paravirt --name f18-i386 --ram
2048 --vcpus 2 -f /dev/vms/f18_i386 --network bridge=virbr0 --location
http://mirrors.rit.edu/fedora/linux//releases/18/Fedora/i386/os/
Starting install...
Retrieving file .treeinfo...                    | 2.4 kB  00:00:00 !!!
Retrieving file vmlinuz-PAE...                  | 9.3 MB  00:00:33 !!!
Retrieving file initrd-PAE.img...               |  52 MB  00:04:11 !!!
Creating domain...

And then, in the virt-viewer window, I see a black screen and all it
says is "serial0 console". using `xl console f18-i386' gives me some of
the textual output of the installer (but nothing graphical, of course).

Both Fedora 18 and rawhide have the following version of Xen:
[xen zhaman ~]$ rpm -qa | grep xen
xen-hypervisor-4.2.2-3.{fc18|fc20}.x86_64
xen-4.2.2-3.{fc18|fc20}.x86_64
...

Regarding libvirt, on F18 I have:
[xen zhaman ~]$ rpm -qa | grep libvirt
libvirt-client-0.10.2.4-1.fc18.x86_64
libvirt-daemon-driver-libxl-0.10.2.4-1.fc18.x86_64
libvirt-daemon-0.10.2.4-1.fc18.x86_64
libvirt-daemon-xen-0.10.2.4-1.fc18.x86_64
...

While, on rawhide:
[xen zhaman ~]$ rpm -qa | grep libvirt
libvirt-client-1.0.5-2.fc20.x86_64
libvirt-daemon-driver-libxl-1.0.5-2.fc20.x86_64
libvirt-daemon-1.0.5-2.fc20.x86_64
libvirt-daemon-xen-1.0.5-2.fc20.x86_64
...

I'm calling it a libxl driver problem since, with both versions, if I
start xend, things work fine, and I can see both the textual and
graphical phases of the Fedora installer in the virt-viewer window from
the very beginning.

I checked in /var/log/libvirt/libxl/libxl.log, but couldn't find
anything particular. Also, I tried to `virsh edit xxx' in the libxl and
xend cases, and the result is attached.

The only difference between the two files that looks relevant to me is
the presence of the following section in the xend version:

    <console type='pty'>
      <target type='xen' port='0'/>
    </console>

However, I tried passing "--console pty,target_type=xen" to virt-install
when using the libxl driver, which caused a similar section to appear in
the XML of that solution too, but _did_NOT_ solve the issue.

Any idea on what can cause this?

Thanks and Regards,
Dario

-- 
<<This happens because I choose it to happen!>> (Raistlin Majere)
-----------------------------------------------------------------
Dario Faggioli, Ph.D, http://about.me/dario.faggioli
Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)

Attachment: virt-edit.libxl
Description: Binary data

Attachment: virt-edit.xend
Description: Binary data

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]