[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Fix starting domains when kernel has no cgroups support



Daniel P. Berrange wrote:
> On Fri, May 10, 2013 at 01:13:20PM -0600, Jim Fehlig wrote:
>   
>> From 63e878b287b98e418b65db46888c1f5d1a01d805 Mon Sep 17 00:00:00 2001
>> From: Jim Fehlig <jfehlig suse com>
>> Date: Fri, 10 May 2013 12:05:00 -0600
>> Subject: [PATCH] Fix starting domains when kernel has no cgroups support
>>
>> Found that I was unable to start existing domains after updating
>> to a kernel with no cgroups support
>>
>>   # zgrep CGROUP /proc/config.gz
>>   # CONFIG_CGROUPS is not set
>>   # virsh start test
>>   error: Failed to start domain test
>>   error: Unable to initialize /machine cgroup: Cannot allocate memory
>>
>> virCgroupPartitionNeedsEscaping() correctly returns errno (ENOENT) when
>> attempting to open /proc/cgroups on such a system, but it was being
>> dropped in virCgroupSetPartitionSuffix().
>>
>> Change virCgroupSetPartitionSuffix() to propogate errors returned by
>>     
>
> s/propogate/propagate/
>
>   
>> its callees.  Also check for ENOENT in qemuInitCgroup() when determining
>> if cgroups support is available.
>> ---
>>  src/qemu/qemu_cgroup.c |  3 ++-
>>  src/util/vircgroup.c   | 23 +++++++++++++++--------
>>  2 files changed, 17 insertions(+), 9 deletions(-)
>>     
>
> ACK
>   

Thanks.  Pushed after fixing the typo.

Regards,
Jim


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]