[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libxl requires libuuid?



On Mon, May 13, 2013 at 04:55:49PM -0600, Eric Blake wrote:
> I got this compile error on a relatively new rawhide machine install:
> 
>   CC       libvirt_driver_libxl_impl_la-libxl_conf.lo
> In file included from /usr/include/libxl.h:259:0,
>                  from libxl/libxl_conf.c:29:
> /usr/include/libxl_uuid.h:27:23: fatal error: uuid/uuid.h: No such file
> or directory
>  #include <uuid/uuid.h>
>                        ^
> compilation terminated.
> 
> Is this a case of the libxl development package not pulling in enough
> pre-reqs?  Does libvirt need to work around this, or do I just file a
> bug against libxl?

The xen-devel RPM needs to gain a 'Requires: libuuid-devel' dep. It isn't
worth working around in libvirt, unless it is currently causing is to see
build failures in Fedora, which I doubt since other things in libvirt's
dep chain likely pull in libuuid-devel already

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]