[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Issues with qemu-nbd over AF_UNIX and virDomainAttachDevice



Il 27/05/2013 12:46, Deepak C Shetty ha scritto:
> On 05/27/2013 02:00 PM, Paolo Bonzini wrote:
>> Il 26/05/2013 15:54, Deepak C Shetty ha scritto:
>>> 3) In nbdxml, i tried removing port="1111".. it didn't give any error
>>> with regards to port beign mandatory.. which si good.. but the attach
>>> device still gives the same error as above
>>>
>>> Is the `nbdxml` I am using for attachign a qemu-nbd exported drive,
>>> correct ?
>> What version of QEMU is this?
>>
>> Can you search the logs for the QMP commands related to the hotplug?
> 
> Do you mean starting my domain using -d option for qemu, which dumps the
> log in /tmp/qemu.log ?

I mean libvirt.log.  You can start libvirtd with these environment
variables:

LIBVIRT_DEBUG=debug LIBVIRT_LOG_OUTPUTS=1:file:/tmp/libvirt.log


> I am using a VM started from virt-manager.... i don't see a way to pass
> -d to it from virt-manager... I can try using a hand-coded qemu cmdline
> tho'
> 
> I assume when i am using python (import libvirt) and/or virsh.. it uses
> qemu-kvm
> qemu-kvm version is 1.0.1

Ok.

> Do i need to try with latest qemu git ?

No, I don't think so, but you can try (1.4.0 or 1.5.0 will do).

> On irc.. you asked me to check if cold-plug works.. but attach-device is
> for active domain only... am i missing something here ?

You can try putting the <disk> item and start the VM.  In this case the
logs in /var/log/libvirt/qemu will be helpful, because they contain the
command-line that is used to start QEMU.

Paolo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]