[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCHv6 1/5] domifaddr: Implement the public APIs



[......]


+ *
+ * If 0 is passed as @flags, libvirt will choose the best way, and won't
+ * include agent in it.

I'm thinking if we don't need to be so complicated, by defaulting to one
of _LEASE or _SNOOP explicitly.

That says (conclusion of all of above), I'm wondering if define the enum like
blow is better.


typedef enum {
VIR_DOMAIN_INTERFACE_ADDRESSES_AGENT = (1 << 1), /* Query qemu guest agent */


And s/AGENT/GUEST_AGENT/, since "AGENT" could mean too much than "guest agent"



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]