[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: require libnl-3 if netcf uses it



On 09/11/2013 02:15 AM, Daniel P. Berrange wrote:
> On Tue, Sep 10, 2013 at 11:52:00AM -0600, Eric Blake wrote:
>> ping; I'm debating about pushing this under the build-breaker rule
>>

>>>
>>> It's much nicer to prevent this at configure time, by requiring that
>>> if we know what netcf used, then we want the same libnl version.  As
>>> before, this can be bypassed by someone who knows what they are doing
>>> by setting LIBNL_CFLAGS (perhaps useful to the rare person where the
>>> build box has a different version of netcf than the installation box).
>>>
>>> * configure.ac (LIBNL): If we can prove netcf used libnl-3, then
>>> don't let configure succeed with libnl-1.
>>>

> 
> ACK
> 

Thanks; pushed.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]