[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Can I request a new release of libvirt-java?





On 09/13/2013 10:29 AM, Daniel Veillard wrote:
On Mon, Sep 02, 2013 at 08:14:33AM +0800, Daniel Veillard wrote:
On Fri, Aug 30, 2013 at 12:31:55PM +0200, Wido den Hollander wrote:
On 08/15/2013 11:00 AM, Wido den Hollander wrote:
Hello,

In the recent months various new methods were added to libvirt-java
which we (Apache CloudStack) would like to use in our KVM code.

For example resizing storage volumes, right now we have to do this with
Bash scripting since although libvirt supports resizing volumes, the
current release (0.4.9) of libvirt-java doesn't.

I don't know if there are any objections, but if possible I'd like to
see 0.5.0 released so we get this new functionality for CloudStack.

We use maven for building CloudStack and it fetches libvirt-java from
libvirt.org/maven2


Can I give this one a small bump?

   Oops, okay, point taken, not sure i can do this today, but I will
try this week !

   Hi Wido,

I tried to do this today, but I hit a problem, when I run ./autobuild.sh
on fedora-19 it starts to build goes fine, was failing in rpm due to
broken (fixed in git now), but for some reason it does not produce
target/libvirt-0.5.0.jar (after fixing the build version to be 0.5.0)
it does build target/libvirt-java-0.5.0.tar.gz
target/libvirt-0.5.0-javadoc.jar and target/libvirt-0.5.0-sources.jar
but not the binary jar. But it does seems to compile correctly:

-------------
....
     [javac] Compiling 64 source files to
/home/veillard/rpms/BUILD/libvirt-java-0.5.0/target/classes

init:
      [copy] Copying 1 file to
/home/veillard/rpms/BUILD/libvirt-java-0.5.0

build:
docs:
     [mkdir] Created dir:
/home/veillard/rpms/BUILD/libvirt-java-0.5.0/target/javadoc
   [javadoc] Generating Javadoc
...
BUILD SUCCESSFUL
Total time: 5 seconds
+ exit 0
....
---------------

   I'm puzzled, how can the build be successful if the main jar is not
generated ???


Odd, I tried building the Deb and that works fine:

wido wido-laptop:~/repos/libvirt-java$ ant deb
Buildfile: /home/wido/repos/libvirt-java/build.xml

init:
    [mkdir] Created dir: /home/wido/repos/libvirt-java/target/classes
    [mkdir] Created dir: /home/wido/repos/libvirt-java/target/testclasses
    [mkdir] Created dir: /home/wido/repos/libvirt-java/target/cache
     [copy] Copying 1 file to /home/wido/repos/libvirt-java

build:
[javac] Compiling 64 source files to /home/wido/repos/libvirt-java/target/classes

jar:
[jar] Building jar: /home/wido/repos/libvirt-java/target/libvirt-0.5.0.jar

deb:
[mkdir] Created dir: /home/wido/repos/libvirt-java/target/libvirt-java/DEBIAN [copy] Copying 1 file to /home/wido/repos/libvirt-java/target/libvirt-java/DEBIAN [mkdir] Created dir: /home/wido/repos/libvirt-java/target/libvirt-java/usr/share/java [copy] Copying 1 file to /home/wido/repos/libvirt-java/target/libvirt-java/usr/share/java [exec] dpkg-deb: building package `libvirt-java' in `target/libvirt-java_0.5.0_all.deb'.

BUILD SUCCESSFUL
Total time: 3 seconds
wido wido-laptop:~/repos/libvirt-java$


The problem with the RPM seems to be it executes "ant build docs"

While "build" actually builds the classes, it doesn't generate a JAR file.

It should run:

$ ant jar docs

That produces the correct .jar file in the target directory.

Wido


Daniel




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]