[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: make autobuild require rpm build deps



On Sat, Sep 14, 2013 at 05:32:52AM -0600, Eric Blake wrote:
> I spent far too long on a new machine trying to figure out why
> ./autobuild.sh failed during the rpm build failure (complaining
> that libvirt_parthelper was supposed to be packaged but was not
> built), and finally traced it to a missing parted-devel
> installation.  I don't know why we have --nodeps in place, but
> removing it would make rpmbuild error out much sooner, and with
> a much less cryptic failure case.
> 
> * autobuild.sh: Drop --nodeps from rpmbuild lines.
> 
> Signed-off-by: Eric Blake <eblake redhat com>
> ---
> 
> I'm okay ditching this patch if someone can explain why the
> --nodeps line should be there.

It is basically an artifact/limitation of the way the automated
builder software works.

We could make it detect whether it is run under the builder
env though - if $AUTOBUILD_COUNTER is not set, then use
--nodeps, otherwise skip it. That'd make it do the right
thing for developers


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]