[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH libvirt-java] Set source and target version to Java 1.6



On 09/17/2013 01:14 PM, Claudio Bley wrote:
At Tue, 17 Sep 2013 10:04:59 +0200,
Wido den Hollander wrote:

On platforms with Java 1.7 it will still produce compatible code
with Java 1.6 platforms

Java 1.6 is still out there and widely used.

AFAIK, the code is 1.5 compliant which would be "least common
denominator". So, there's no need raising the bar to 1.6 actually.


You are correct, I tried to set target and source to 1.5 and that compiled flawlessly.


The question is, do we (need to) care about 1.5?


As far as I know there are no support distributions which still ship with 1.5

The platforms which ship with 1.6:
- RHEL 5 and 6
- Ubuntu 10.04 and 12.04

RHEL 6 and Ubuntu 12.04 also support 1.7.

But since the code is 1.5 compliant I won't complain if we set target and source to 1.5. Although I don't think there are any 1.5 users left who use libvirt-java

Wido

/ Claudio



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]