[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH glib] Disable test suite unless glib >= 2.38



On Thu, Feb 20, 2014 at 04:24:52PM +0000, Daniel P. Berrange wrote:
> diff --git a/tests/Makefile.am b/tests/Makefile.am
> index 56887ce..8cb98e5 100644
> --- a/tests/Makefile.am
> +++ b/tests/Makefile.am
> @@ -1,3 +1,11 @@
> +EXTRA_DIST = \
> +	xml/gconfig-domain.xml \
> +	xml/gconfig-domain-clock.xml \
> +	xml/gconfig-domain-os.xml \
> +	$(NULL)
> +
> +if ENABLE_TESTS
> +
>  include $(top_srcdir)/build-aux/glib-tap.mk
>  
>  AM_CFLAGS = \
> @@ -14,7 +22,9 @@ LDADD = \
>  
>  test_programs = test-gconfig test-events
>  
> -dist_test_data = \
> -	xml/gconfig-domain.xml \
> -	xml/gconfig-domain-clock.xml \
> -	xml/gconfig-domain-os.xml
> +else
> +EXTRA_DIST += \
> +	test-events.c \
> +	test-gconfig.c \
> +	$(NULL)
> +endif

This is already committed, and not really important, but the else/endif
block is not needed (on newer automake?) as when deciding which files to
put in the tarball, it ignores the conditionals and picks all files which
would be included for either value of the conditional.

Christophe

Attachment: pgpIANp6VfdMD.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]