[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Compiling libvirt RPC client library for QNX



Hi Eric,
I used the option '--without-macvtap' and I was able to compile on my
linux box. When I compiled, I see many libraries are getting built. But as
I have explained my requirement earlier, I just need a RPC client library,
essentially the option '--with-remote'.

If I check .c files I see only './src/libvirt.c' and './tools/virsh.c' are
the two files where '# ifdef WITH_REMOTE' is present.

Does it mean that as per my requirement I only need to compile these files?

My intent is to have a library with minimal files which suffice to my
requirement. Because that way it will be easier for me to compile them on
QNX.

You have mentioned on another thread that in a weeks time some new version
of libvirt will come which we can compile for non-linux machines ? What
change is coming in that  version ? The latest version of libvirt can not
be compiled for QNX ?


Regards
Ritesh Sharma

On 24/02/14 10:15 PM, "Eric Blake" <eblake redhat com> wrote:

>On 02/24/2014 05:58 AM, Panday Ritesh Sharma (rpanday) wrote:
>
>[please don't top-post on technical lists]
>
>> Hi Roman,
>> Before I jump to the compilation of libvirt for QNX, I thought of
>> compiling it on linux with my required options. So that I will be
>>knowing
>> what all files are of my use (from compilation log). For that I ran
>> ./configure with below option and then tried 'make'. But 'make'
>>complains
>> there is no 'makefile' and I need to run './configure' before I run
>> 'make'. Please see the log below. Am I missing any thing here ?
>> 
>
>> checking whether to compile with virtual port support... yes
>> checking for LIBNL... no
>> configure: error: libnl-devel >= 1.1 is required for macvtap support
>> 
>
>You missed reading this error message.  You either need libnl-devel
>installed, or to pass additional --without-* options to configure that
>avoid whatever was assuming that libnl was required (based on the error
>message, you might have luck with './configure --without-macvtap' if you
>aren't in the mood to install things).  It may also be worth patching
>libvirt to behave saner by automatically avoiding macvtap when libnl is
>not available; patches are welcome, but it's lower priority for most
>developers, since most of us tend to build on machines with all the
>prereqs installed rather than focusing on minimal builds.
>
>> blr-vxr-052~$ make
>> There seems to be no Makefile in this directory.
>> You must run ./configure before running `make'.
>> make: *** [abort-due-to-no-makefile] Error 1
>> blr-vxr-052~$
>
>Therefore it is no surprise that there was no makefile created.
>Oftentimes, I recommend using './configure && make' rather than
>'./configure; make', so that 'make' is not attempted if configure fails.
>
>-- 
>Eric Blake   eblake redhat com    +1-919-301-3266
>Libvirt virtualization library http://libvirt.org
>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]