[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] spec: Use correct versions of libgfapi in RHEL builds



On Wed, Feb 26, 2014 at 01:09:48PM +0100, Peter Krempa wrote:
> RHEL still uses the 3.4.0 package of libgfapi and the package is built
> only for x86_64.
> ---
>  libvirt.spec.in | 14 +++++++++++++-
>  1 file changed, 13 insertions(+), 1 deletion(-)
>
> diff --git a/libvirt.spec.in b/libvirt.spec.in
> index 3d5a69e..67b5557 100644
> --- a/libvirt.spec.in
> +++ b/libvirt.spec.in
> @@ -98,7 +98,7 @@
>  %else
>      %define with_storage_sheepdog 0
>  %endif
> -%if 0%{?fedora} >= 19
> +%if 0%{?fedora} >= 19 || 0%{?rhel >= 6}

Be consistent, this ...

>      %define with_storage_gluster 0%{!?_without_storage_gluster:%{server_drivers}}
>  %else
>      %define with_storage_gluster 0
> @@ -153,6 +153,13 @@
>      %define with_numactl 0
>  %endif
>
> +# libgfapi is built only on x86_64 on rhel
> +%ifnarch x86_64
> +    %if 0%{?rhel >= 6}

... and this doesn't look like ...

> +        %define with_storage_gluster 0
> +    %endif
> +%endif
> +
>  # RHEL doesn't ship OpenVZ, VBox, UML, PowerHypervisor,
>  # VMWare, libxenserver (xenapi), libxenlight (Xen 4.1 and newer),
>  # or HyperV.
> @@ -571,9 +578,14 @@ BuildRequires: ceph-devel
>      %endif
>  %endif
>  %if %{with_storage_gluster}
> +%if 0%{?rhel} >= 6

... this, which is the only one that'll work, I guess.

BTW: If 3.4.0 is enough, why are we requiring 3.4.1 somewhere?

Martin

> +BuildRequires: glusterfs-api-devel >= 3.4.0
> +BuildRequires: glusterfs-devel >= 3.4.0
> +%else
>  BuildRequires: glusterfs-api-devel >= 3.4.1
>  BuildRequires: glusterfs-devel >= 3.4.1
>  %endif
> +%endif
>  %if %{with_numactl}
>  # For QEMU/LXC numa info
>  BuildRequires: numactl-devel

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]