[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Release of libvirt-python-1.2.10



On Tue, Nov 04, 2014 at 10:49:46AM -0800, Jason Helfman wrote:
> On Mon, Nov 3, 2014 at 1:21 AM, Daniel Veillard <veillard redhat com> wrote:
> 
> >  I also tagged and pushed a new version of libvirt-python,
> > it is available at:
> >
> >   ftp://libvirt.org/libvirt/python
> >
> > it handle the new header split in libvirt-1.2.10 and fixes a
> > number of issues:
> >
> > Documentation:
> > d Change the comment in getPyNodeCPUCount method reflecting correct called
> > methods (Pradipta Kr. Banerjee)
> >
> > Bug Fixes:
> > b virDomainBlockCopy: initialize flags to 0 (Pavel Hrdina)
> > b flags cannot get right value for blockCopy function (Pavel Hrdina)
> > b Fix rest of unsigned integer handling (Peter Krempa)
> > b Fix parsing of 'flags' argument for bulk stats functions (Luyao Huang)
> > b Fix function name when parsing arguments in libvirt_virNodeAllocPages
> > (Peter Krempa)
> >
> > Improvements:
> > i fix libvirt headers list (Dmitry Guryanov)
> > i Improve error output when use getTime with a nonzero flags. (Luyao Huang)
> > i setup.py: fix rpm build to return 1 on error (Pavel Hrdina)
> > i sanitytest: define long for python version >= 3 (Martin Kletzander)
> > i sanitytest: count with the fact that large enums can be long (Martin
> > Kletzander)
> > i sanitytest: check for exported enums (Martin Kletzander)
> >
> >   Thanks everybody who contributed to this release !
> >
> > Daniel
> 
> 
> Hello All,
> 
> I am not able to build this, and receive this error.
> 
> building 'libvirtmod' extension
> cc -DNDEBUG -O2 -pipe -fstack-protector -fno-strict-aliasing -fPIC -I.
> -I/usr/local/include/python2.7 -c libvirt-override.c -o
> build/temp.freebsd-10.0-RELEASE-p10-amd64-2.7/libvirt-override.o
> -I/usr/local/include
> In file included from libvirt-override.c:21:
> /usr/local/include/libvirt/libvirt.h:92:11: fatal error:
> 'libvirt/libvirt-host.h' file not found
> # include <libvirt/libvirt-host.h>
>           ^
> 1 error generated.
> error: command 'cc' failed with exit status 1
> *** Error code 1
> 
> Any ideas?
> 
> I do have libvirt installed....

  You need libvirt-1.2.10 or later installed, because of the
header split for the drivers,

Daniel

-- 
Daniel Veillard      | Open Source and Standards, Red Hat
veillard redhat com  | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]