[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v7 4/7] qemu: Add bps_max and friends qemu driver



On 10.11.2014 16:19, Matthias Gatto wrote:
Add support for bps_max and friends in the driver part.
In the part checking if a qemu is running, check if the running binary
support bps_max, if not print an error message, if yes add it to
"info" variable

This patch follow therse patchs: http://www.redhat.com/archives/libvir-list/2014-November/msg00271.html
I've fix the syntax error and the nparams detection problem

Signed-off-by: Matthias Gatto <matthias gatto outscale com>
---
  include/libvirt/libvirt-domain.h |  56 +++++++++++
  src/qemu/qemu_driver.c           | 197 ++++++++++++++++++++++++++++++++++++---
  src/qemu/qemu_monitor.c          |  10 +-
  src/qemu/qemu_monitor.h          |   6 +-
  src/qemu/qemu_monitor_json.c     |  11 ++-
  src/qemu/qemu_monitor_json.h     |   6 +-
  tests/qemumonitorjsontest.c      |   4 +-
  7 files changed, 264 insertions(+), 26 deletions(-)

I've capped the long lines and

ACK.

Moreover, I've merged the patches. Congratulations on your first libvirt contribution!

Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]