[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] configure: Check for libxl_utils.h instead of libxlutil.h



The file provided by xen-devel package (or xen-tools in Gentoo)
does not provide libxlutil.h. In fact the package provides
libxl_utils.h instead which is the one we are looking for anyway.

Signed-off-by: Michal Privoznik <mprivozn redhat com>
---
 configure.ac | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 38fbbad..0626492 100644
--- a/configure.ac
+++ b/configure.ac
@@ -915,7 +915,7 @@ fi
 
 if test "$with_libxl" = "yes"; then
     dnl If building with libxl, use the libxl utility header and lib too
-    AC_CHECK_HEADERS([libxlutil.h])
+    AC_CHECK_HEADERS([libxl_utils.h])
     LIBXL_LIBS="$LIBXL_LIBS -lxlutil"
     AC_DEFINE_UNQUOTED([WITH_LIBXL], 1, [whether libxenlight driver is enabled])
     if test "x$LIBXL_FIRMWARE_DIR" != "x"; then
-- 
2.0.5


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]