[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Xen-devel] [libvirt test] 50401: regressions - FAIL



On Wed, Apr 15, 2015 at 11:17:29AM +0100, Ian Campbell wrote:
> On Tue, 2015-04-14 at 10:37 +0100, Daniel P. Berrange wrote:
> > On Tue, Apr 14, 2015 at 10:33:45AM +0100, Ian Campbell wrote:
> > > On Tue, 2015-04-14 at 02:27 +0000, osstest service user wrote:
> > > > flight 50401 libvirt real [real]
> > > > http://logs.test-lab.xenproject.org/osstest/logs/50401/
> > > > 
> > > > Regressions :-(
> > > > 
> > > > Tests which did not succeed and are blocking,
> > > > including tests which could not be run:
> > > >  build-armhf-libvirt           5 libvirt-build             fail REGR. vs. 50368
> > > [...]
> > > Per
> > > http://logs.test-lab.xenproject.org/osstest/logs/50401/build-armhf-libvirt/5.ts-libvirt-build.log this is:
> > > 
> > > qemu/qemu_driver.c: In function 'qemuDomainAddCgroupForThread':
> > > qemu/qemu_driver.c:4641:34: error: declaration of 'index' shadows a global declaration [-Werror=shadow]
> > > qemu/qemu_driver.c: In function 'qemuDomainHotplugAddPin':
> > > qemu/qemu_driver.c:4674:29: error: declaration of 'index' shadows a global declaration [-Werror=shadow]
> > > qemu/qemu_driver.c: In function 'qemuDomainHotplugPinThread':
> > > qemu/qemu_driver.c:4702:32: error: declaration of 'index' shadows a global declaration [-Werror=shadow]
> > > qemu/qemu_driver.c: In function 'qemuDomainDelCgroupForThread':
> > > qemu/qemu_driver.c:4733:34: error: declaration of 'index' shadows a global declaration [-Werror=shadow]
> > > cc1: all warnings being treated as errors
> > > 
> > > 
> > > This seems to be a general issue unrelated to Xen.
> > > 
> > > > version targeted for testing:
> > > >  libvirt              b487bb810ec95df862e7e80468c8e861ed80b0cb
> > > > baseline version:
> > > >  libvirt              225aa80246d5e4a9e3a16ebd4c482525045da3db
> > > 
> > > After a quick glance I don't see a fix post-b487bb810ec9 either in
> > > master or on the libvirt list.
> > > 
> > > Looking at the range under test it looks like one or more of John's
> > > changes is adding parameters called index, shadowing index(3) from
> > > <strings.h>.
> > 
> > Yeah, we've had this problem several times before - we usually just
> > do a s/index/idx/ or similar to address it.
> 
> I see this is now fixed in libvirt.git#master, thanks.
> 
> However, I would just comment that contrary to the commit message, I
> don't think there is anything the Xen build has done which caused this,
> I think it's down to the LIBVIRT_COMPILE_WARNINGS macro which ends up
> enabling Wshadow if it was available on the system which ran autogen and
> on the compiling system.
> 
> Our builds run on Debian Wheezy, which IIRC uses gcc 4.4 which isn't
> unusual...

Yeah, there is nothing Xen specific about the problem - it is entirely
down to the build toolchain & compiler options.

Regards,
Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]