[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] maint: update to latest gnulib



Incorporates fixes for cross-compiling to mingw on rawhide, where
gcc 5.1 changes detection of how to properly determine PRIdMAX.

* .gnulib: Update to latest, for mingw.

Signed-off-by: Eric Blake <eblake redhat com>
---

I've missed the freeze for rc1, but confirmed that this update
is rather minimal and should only affect mingw (in particular, it
will fix cross-compilation failure under rawhide with gcc 5.1).

As such, I won't push without review, but I also argue that the
changeset is small enough that it should be safe if we agree to
take it before rc2.

* .gnulib 875ec93...c26527c (5):
  > stdio: limit __gnu_printf__ witness to gcc 4.4+
  > error: use correct printf attributes on mingw
  > update from texinfo
  > inttypes: force correct mingw PRIdMAX even without <stdio.h>
  > stdio: fix probe on mingw under gcc 5.1

 .gnulib | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/.gnulib b/.gnulib
index 875ec93..c26527c 160000
--- a/.gnulib
+++ b/.gnulib
@@ -1 +1 @@
-Subproject commit 875ec93e1501d2d2a8bab1b64fa66b8ceb51dc67
+Subproject commit c26527cebbbf42ed1dbc50df0074861e0ebe33dc
-- 
2.1.0


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]