[libvirt] [PATCH v3 00/11] clean up after slot sharing patches

Laine Stump laine at laine.org
Mon Dec 19 15:25:18 UTC 2016


(rebase of the original patches to make review easier)

Some of the patches that enabled sharing PCI slots by multiple
pcie-root-ports made the idea of reserving an entire slot obsolete. To
reduce confusion and misunderstandings, this patch series gets rid of
the name "Slot" in all of the functions that reserve and release PCI
addresses.

Laine Stump (11):
  conf: fix fromConfig argument to virDomainPCIAddressReserveAddr()
  conf: fix fromConfig argument to virDomainPCIAddressValidate()
  conf: rename virDomainPCIAddressGetNextSlot() to ...GetNextAddr()
  conf: eliminate virDomainPCIAddressReserveNextSlot()
  qemu: replace virDomainPCIAddressReserveAddr with
    virDomainPCIAddressReserveSlot
  conf: make virDomainPCIAddressReserveAddr() a static function
  conf: rename virDomainPCIAddressReserveAddr() to ...Internal()
  conf: rename virDomainPCIAddressReserveSlot() to ...Addr()
  qemu: remove qemuDomainPCIAddressReserveNextAddr()
  qemu: rename qemuDomainPCIAddressReserveNextSlot() to ...Addr()
  conf: eliminate virDomainPCIAddressReleaseSlot() in favor of ...Addr()

 src/bhyve/bhyve_device.c       |  26 ++++++----
 src/conf/domain_addr.c         |  60 +++++------------------
 src/conf/domain_addr.h         |  15 ------
 src/libvirt_private.syms       |   4 +-
 src/qemu/qemu_domain_address.c | 105 ++++++++++++++++++++---------------------
 5 files changed, 80 insertions(+), 130 deletions(-)

-- 
2.7.4




More information about the libvir-list mailing list