[libvirt] [PATCH 4/7] hostdev: Add detachPCIDevices()

Daniel P. Berrange berrange at redhat.com
Fri Jan 22 17:38:10 UTC 2016


On Fri, Jan 22, 2016 at 06:30:42PM +0100, Andrea Bolognani wrote:
> On Fri, 2016-01-22 at 15:02 +0000, Daniel P. Berrange wrote:
> > On Tue, Jan 19, 2016 at 04:36:06PM +0100, Andrea Bolognani wrote:
> > > This function mirrors reattachPCIDevices().
> > > 
> > > The handling of active and inactive devices is updated and made more
> > > explicit, which means virHostdevPreparePCIDevices() has to be
> > > updated as well.
> > > ---
> > >  src/util/virhostdev.c | 125 ++++++++++++++++++++++++++++++--------------------
> > >  1 file changed, 76 insertions(+), 49 deletions(-)
> > > 
> > > diff --git a/src/util/virhostdev.c b/src/util/virhostdev.c
> > > index 74c43f2..2d219dd 100644
> > > --- a/src/util/virhostdev.c
> > > +++ b/src/util/virhostdev.c
> > > @@ -593,6 +593,56 @@ reattachPCIDevices(virHostdevManagerPtr mgr,
> > >      return ret;
> > >  }
> > >  
> > > +/**
> > > + * detachPCIDevices:
>> > Please keep a virHostdev prefix on this method, and also on the
> > one added in the earlier patch. All methods should be prefixed
> > to match the filename, even if they're static
> 
> I wanted to avoid having
> 
>   virHostdevReattachPCIDevice()

How about virHostdevReAttachPCIDeviceKMod() since this method
is specifically only doing the kmod rebind.

>   virHostdevPCINodeDeviceReAttach()
>   virHostdevReAttachPCIDevices()
> 
> and I couldn't come up with a better name myself. Any ideas? :)

Regards,
Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|




More information about the libvir-list mailing list