[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] current master failed to compile



2016-03-15 15:08 GMT+03:00 Vasiliy Tolstov <v tolstov selfip ru>:
>> What version of libgcrypt or gnutls do you use?  Or is it something else
>> that provides that struct.  It works fine for me with libgcrypt-1.6.5
>> and gnutls-3.3.22.  There should be some sort of guidance somewhere what
>> to use instead of that.  I believe it's also the reason for the other
>> errors below.


I'm update libgrcypt but error still exists:
libvirt.c:323:15: error: 'gcry_thread_cbs' is deprecated
[-Werror=deprecated-declarations]
 static struct gcry_thread_cbs virTLSThreadImpl = {
               ^
In file included from libvirt.c:58:0:
/usr/x86_64-pc-linux-gnu/include/gcrypt.h:211:8: note: declared here
 struct gcry_thread_cbs
        ^
libvirt.c:331:5: error: excess elements in struct initializer [-Werror]
     virTLSMutexInit,
     ^
libvirt.c:331:5: note: (near initialization for 'virTLSThreadImpl')
libvirt.c:332:5: error: excess elements in struct initializer [-Werror]
     virTLSMutexDestroy,
     ^
libvirt.c:332:5: note: (near initialization for 'virTLSThreadImpl')
libvirt.c:333:5: error: excess elements in struct initializer [-Werror]
     virTLSMutexLock,
     ^
libvirt.c:333:5: note: (near initialization for 'virTLSThreadImpl')
libvirt.c:334:5: error: excess elements in struct initializer [-Werror]
     virTLSMutexUnlock,
     ^
libvirt.c:334:5: note: (near initialization for 'virTLSThreadImpl')


-- 
Vasiliy Tolstov,
e-mail: v tolstov selfip ru


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]