[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] current master failed to compile



  Vasiliy Tolstov wrote:

> 2016-03-15 14:39 GMT+03:00 Martin Kletzander <mkletzan redhat com>:
> > What version of libgcrypt or gnutls do you use?  Or is it something else
> > that provides that struct.  It works fine for me with libgcrypt-1.6.5
> > and gnutls-3.3.22.  There should be some sort of guidance somewhere what
> > to use instead of that.  I believe it's also the reason for the other
> > errors below.
> 
> 
> I'm try to update, my gcrypt version is 1.6.4 and gnutls 3.4.8

This is weird because gnutls 3.x does not use gcrypt. So
WITH_GNUTLS_GCRYPT should not be defined and therefore gcrypt.h should
not be included.

Probably there's an issue with your system or a bug in configure.
You might check how configure tries to find gnutls. Or, to start with,
run "pkg-config --libs 'gnutls >= 3.0'" to check if it sees gnutls 3.x on
your system.

Roman Bogorodskiy


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]