[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] spec: Include KVM support on RHEL 7 ppc64 and newer



---
Definitely not an expert on spec files, but I did a test build
on RHEL 7.2 ppc64le and it resulted in

  libvirt-daemon-driver-qemu-1.3.3-1.el7.ppc64le.rpm
  libvirt-daemon-kvm-1.3.3-1.el7.ppc64le.rpm
  libvirt-lock-sanlock-1.3.3-1.el7.ppc64le.rpm

being built in addition to what was built even before, so it
looks reasonable I guess? Comments very welcome :)

 libvirt.spec.in | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index 03e2438..fdea12a 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -77,7 +77,11 @@
 
 %if 0%{?rhel}
     %define with_qemu_tcg 0
-    %define qemu_kvm_arches x86_64
+    %if 0%{?rhel} >= 7
+        %define qemu_kvm_arches x86_64 %{power64}
+    %else
+        %define qemu_kvm_arches x86_64
+    %endif
 %endif
 
 %ifarch %{qemu_kvm_arches}
-- 
2.5.0


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]