[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] virtual machine won't autostart when using LVM with cache



On 03/21/2016 12:28 PM, David Hlacik wrote:
> Hello guys,
> 
> OS Fedora 23 with latest updates
> 
> Recently I have switched to use LVM cache feature on logical volume
> /dev/hdd/windata1 to improve it performace using 32GB partition from SSD disk.
> 
> However, when my computer will start, my virtual machine won't autostart 
> 
> Mar 21 10:48:57 brutus-coreos libvirtd[956]: Cannot access storage file
> '/dev/hdd/windata1' (as uid:107, gid:107): No such file or directory
> Mar 21 10:48:57 brutus-coreos libvirtd[956]: Failed to autostart VM 'winos1':
> Cannot access storage file '/dev/hdd/windata1' (as uid:107, gid:107): No such
> file or directory
> Mar 21 10:48:57 brutus-coreos libvirtd[956]: Cannot access storage file
> '/dev/hdd/windata1' (as uid:107, gid:107): No such file or directory
> 
> It seems that when using LVM cache, one have to wait till it will inicialize?
> 
> When I will manually start virtual machine afterwards, everything works OK :
> 
> [root brutus-coreos ~]# virsh start winos1
> Domain winos1 started
> 
> I have tried to remove LVM cache from  /dev/hdd/windata1 and afterward
> autostart works! So it must be LVM cache related.
> 
> Can you please help me to solve this ?
> 
> Thanks in advance
> 

Maybe override the system libvirtd unit file to wait for LVM. There's some
details here, but I didn't test it:

https://ask.fedoraproject.org/en/question/10419/how-to-start-a-systemd-unit-only-after-lvm-is-up/

- Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]