[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] libxl: fix default vram setting for implicit video device



On Tue, May 10, 2016 at 11:01:17PM -0600, Jim Fehlig wrote:
> Commit 6879be48 moved adding of an implicit video device after XML
> parsing. As a result, libxlDomainDeviceDefPostParse() is no longer
> called to set the default vram when adding an implicit device.
> Commit 6879be48 assumes virDomainVideoDefaultRAM() will set the
> default vram, but it returns 0 if the domain virtType is
> VIR_DOMAIN_VIRT_XEN.

I think it would be nicer if PostParse would add a proper device
with vram set correctly.

I have proposed a series that fills (v)ram in post-parse even for
implicit devices, would that fix the problem?

cover 1462963982 git jtomko redhat com
https://www.redhat.com/archives/libvir-list/2016-May/msg00728.html

Jan

> Attempting to start an HVM domain with vram=0
> results in
> 
> error: unsupported configuration: videoram must be at least 4MB for CIRRUS
> 
> The default vram setting for Xen HVM domains depends on the device
> model used (qemu-xen vs qemu-traditional), hence setting the
> default is deferred to libxlDomainDeviceDefPostParse().
> 
> This patch addresses the problem during creation of the video
> device. If vram is 0, it is assumed unset and the default
> (depending on qemu-xen vs qemu-traditional) is applied.
> 
> Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1334557
> Signed-off-by: Jim Fehlig <jfehlig suse com>
> ---
>  src/libxl/libxl_conf.c | 38 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 38 insertions(+)
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]